Factorial Program in C: A Comprehensive Guide

https://www.cpmrevenuegate.com/chcqd3sk?key=68c59e57e5636c8d14c89b64cf943794 Factorial Program in C: A Comprehensive Guide Introduction Factorials might seem like a simple mathematical concept, but they play a significant role in both mathematics and programming. Whether you’re working on combinatorial problems, probability calculations, or even certain algorithms in data science, understanding how to calculate factorials efficiently is crucial. In this article, we’ll dive deep into the concept of factorials, explore various methods to implement them in the C programming language, and analyze their use cases. Understanding Factorial in Mathematics Before jumping into the coding part, let's first clarify what a factorial is. A factorial, denoted by an exclamation mark (n!), is the product of all positive integers up to a given number.  For example: - 5! = 5 × 4 × 3 × 2 × 1 = 120 The factorial of a number is defined as: \[ n! = n × (n-1) × (n-2) × ... × 2 × 1 \] Factorials are cruc

Beecrowd 1012-Area solution C, CPP and Python

 



Beecrowd 1012-Area solution C, CPP and Python

Question link

beecrowd | 1012

Area

Make a program that reads three floating point values: A, B and C. Then, calculate and show:
a) the area of the rectangled triangle that has base A and height C.
b) the area of the radius’s circle C. (pi = 3.14159)
c) the area of the trapezium which has A and B by base, and C by height.
d) the area of ​​the square that has side B.
e) the area of the rectangle that has sides A and B.

Input

The input file contains three double values with one digit after the decimal point.

Output

The output file must contain 5 lines of data. Each line corresponds to one of the areas described above, always with a corresponding message (in Portuguese) and one space between the two points and the value. The value calculated must be presented with 3 digits after the decimal point.

Input SamplesOutput Samples
3.0 4.0 5.2TRIANGULO: 7.800
CIRCULO: 84.949
TRAPEZIO: 18.200
QUADRADO: 16.000
RETANGULO: 12.000
12.7 10.4 15.2TRIANGULO: 96.520
CIRCULO: 725.833
TRAPEZIO: 175.560
QUADRADO: 108.160
RETANGULO: 132.080

Beecrowd 1012-Area solution in C

Solution :

#include<stdio.h>

int main() {
double A,B,C,t,pi,c,tra,s,rec;
scanf("%lf%lf%lf",&A,&B,&C);
pi=3.14159;
t=.5AC;
c=piCC;
tra=.5(A+B)C;
s=BB; rec=AB;
printf("TRIANGULO: %.3lf\nCIRCULO: %.3lf\nTRAPEZIO: %.3lf\nQUADRADO: %.3lf\nRETANGULO: %.3lf\n",t,c,tra,s,rec);

return 0;

}

Beecrowd 1012-Area solution in Python

import math

A, B, C = map(float, input().split())
pi = 3.14159
t = 0.5 * A * C
c = pi * (C ** 2)
tra = 0.5 * (A + B) * C
s = B ** 2
rec = A * B
print(f"TRIANGULO: {t:.3f}")
print(f"CIRCULO: {c:.3f}")
print(f"TRAPEZIO: {tra:.3f}")
print(f"QUADRADO: {s:.3f}")
print(f"RETANGULO: {rec:.3f}")

Next problem :Beecrowd 1013- The Greatest solution

Comments

Popular posts from this blog

URI online judge solution1011 Sphere solution

Beecrowd1009 – Salary with Bonus solution with C